Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «Actual Windows Manager calls home a LOT, reason? » on forum: Technical Support   Views: 8888
 
A Murder of Crows
Registered user
 
Posts: 1
Joined: 05/09/2020
Posted: 05/09/2020 07:01:54
 
 
I figure the only requirement for AWM to have to use the internet for is an update check.

I purposefully blocked AWM from accessing the internet and i started getting constant notices that it was trying to connect.

I just checked today and saw that the automatic update check option was still enabled. I updated to the latest version and disabled that check, so i'm hoping it won't attempt to connect to the internet any longer.

Question is, if an internet connection is not available to AWM, it seems to want to hammer networking without informing the user. Is this the intended design? How many checks does AWM make and how often?
 
Top
Syrinx
Registered user
 
Posts: 28
Joined: 12/16/2016
Posted: 05/11/2020 04:49:05
 
 
My firewall is set to block all outbound and inbound connections by default. I've never made any allowed rules rules for AWM but can't find a single block and it starts shortly after login and remains running. I even tried launching the configuration tool as well, nothing even trying to make a peep out on this end. Note I do have Auto update checks and beta version checks disabled. I'm using 8.14.3 downloaded from https://www.actualtools.com/files/aimsetup.exe, maybe grab that again and re-install to see if it helps on your end?
 
Top
Alex Fadeyev
Administrator

Moderator
 
Posts: 1429
Joined: 09/30/2005
Posted: 05/15/2020 01:01:18
 
 
Our products try to connect automatically to our web server in two cases:

1) to check if a new version available (controlled by the Automatically option)

2) to upload collected telemetry data (controlled by the Collect usage statistics option)

If the options are disabled then the program should not attempt to connect to the Internet.

If you disabled to auto-updating but the program still tries to connect to our website then it's probably a bug. Please send us your configuration for analysis.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register