Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «Howto: Fix for Intel GPU with nVidia Optimus GPU , Is the new release 8.13 causing stutter with defined hardware? » on forum: Technical Support   Views: 4600
 
Angry Kitty
Registered user

 
Posts: 9
Joined: 27.05.2018
Posted: 25.08.2018 17:52:37
 
 
Windows 10, x64, Intel Integrated GPU, Intel nVidia Optimus
Software: Actual Multiple Monitors

After updating to latest release 8.13  fr om 8.12 I noticed the differences is the following.

Releaes 8.13 does something described below:

* System uses Intel Integrated GPU under CPU Interposer by default.
* nVidia GPU with Optimus wakes up every 5 seconds very short but very noticable.

This problem has existed a long time in Windows 10 itsself, that is why I recognized the symptom.

Description for anyone in the past in this situation that resolved when Microsoft released Windows 10, 1803 in beginning of 2018.

https://communities.intel.com/thread/119093

If you rely on the following functions of Actual Multiple Monitors, you might experience described problem.

* Windows Layout
* Windows Snapping

If you do need those options you either have to force the nVidia Active all the time, or either force the Intel GPU active all the time.

* Tiny application to force nVidia GPU all the time active and disabling Intel GPU here https://github.com/jobeid/TrayPwrD3
* If you want to use the Intel GPU only, then in configuration panel, go to hardware, and disable nVidia GPU by right clicking that device and do that in mouse popup menu.

But as mentioned, you can also do the following.

* Disable everything in Windows Layout
* Disable everything in Windows Snapping

Since I use Actual Multiple Monitors without described functions of Actual Multiple Monitors I did the latter. Now nVidia Optimus works fine without Actual Multiple Monitor Tools waking up the nVidia GPU and transitioning its output bypassing Intel Integrated GPU. ( That is the moment you experience as stutter every 5 seconds. )

And if you rely on the functions, TrayPwrD3 tested fine with same result but it will draw a more energy.


It is coincidence that only came up to me to understand when I installed the official release 8.13 since the Beta had it too.

The programmers of Actual Multiple Monitor Tools probably know wh ere to find this in their codepath.

If you have only 1 GPU you are not affected by this specific hardware transition microstutter of the entire Microsoft Operating System.  :idea:

Having Technology Anger Management therapy since Microsoft Windows 95
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3633
Joined: 04.04.2012
Posted: 28.08.2018 01:47:14
 
 
Hello, Angry Kitty

Are you sure the problem doesn't persist in 8.12 version of Actual Multiple Monitors?

Could you also temporarily install the 8.12.2 version and see whether the problem persist in that version?

Are you sure the problem is associated with switching to discrete nVidia graphics card and forcing the nVidia or Intel GPU Active all the time solves this exact problem? Have you tried it this time?

Best regards.
 
Top
Angry Kitty
Registered user

 
Posts: 9
Joined: 27.05.2018
Posted: 30.08.2018 21:16:25
 
 
Quote
Bogdan Polishchuk wrote:
Hello, Angry Kitty

Are you sure the problem doesn't persist in 8.12 version of Actual Multiple Monitors?

Could you also temporarily install the 8.12.2 version and see whether the problem persist in that version?

Are you sure the problem is associated with switching to discrete nVidia graphics card and forcing the nVidia or Intel GPU Active all the time solves this exact problem? Have you tried it this time?

Best regards.

A single call to a DirectX might wakeup the suddenly Windows 10 Optimus sequence activating nVidia Discrete GPU, including stuttering from Intel Integrated GPU to transgression towards nVidia GPU.

Probably I can find another work around, far I would like.

In nVidia control panel a person can say, all your programs are confined to Integrated Intel GPU. ( Not the CPU, but GPU. )

I would like to try it, but I see many executables in the installation folder, I would have to force them in nVidia Control Panel to only use Integrated Intel GPU. ( with a G ).

In my case, I need the by you provided taskbar which works great, don't have to power on primary monitor even.

This is a mitigation.

In 8.12 it did not exist.
In 8.13 it is exactly in 5 seconds interval you described as enhancement in your changelog.

But remember, people with a single GPU either nVidia or AMD are not affected. Only laptop users, like Optimus as I.

Wish Windows 10 would give a single DirectX call or whatever it causes to not force transition from Integrated Intel GPU to nVidia Optimus Discrete GPU.

For me it's OK.

Currently don' t have time to force all your executables in installation folder set at Intel Integrated GPU. But I suppose that would work. Since if inside your executables you would call a call activating Optimus, it would be mitigated.

You have power users, from which I think they are not affacted at all, only laptop users with Intel GPU and nVidia Optimus from 8.13 onwards are affected.

Mitigation is simple as described, not having time to mitigate it by programming nVidia Control Centre. Hope for your understanding.

Edit: Will look if I have time to program nVidia Control Panel to set all your executables at Intel Discrete Integrated GPU. That would make all functions I disabled ( but in my case I do not use ) make availlable. But remember, this issue is only solved since 18.03 release of Windows 10 itself as in the opening topic is described, Optimus users world wide had same problem, not using anything but a clean Windows 10.

Having Technology Anger Management therapy since Microsoft Windows 95
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3633
Joined: 04.04.2012
Posted: 31.08.2018 14:09:32
 
 
Angry Kitty,

Quote
Are you sure the problem is associated with switching to discrete nVidia graphics card and forcing the nVidia or Intel GPU Active all the time solves this exact problem? Have you tried it this time?
I asked this to see whether you're sure the problem in this case is associated with nVidia Optimus technology, because there may be other causes of this stuttering.
Clarify please, apart from the fact the problem looks similar to the Windows 10 one, why you think the switch from integrated to the discrete graphics card happens in this case?

Quote
But as mentioned, you can also do the following.

* Disable everything in Windows Layout
* Disable everything in Windows Snapping

Could you please check, whether disabling the Windows Layout feature alone is enough to make the problem disappear. Enable the options which are enabled by default in the Windows Snapping section: Classic, Aero Snap, Suspend on, Disable the native Windows 7 Snap.

Best regards.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register