Forums list
New topics
Topics list
Search
Help
Login
Register

Messages 11 - 20 of 53
First | Prev. | 1 2 3 4 5 | Next | Last 

Topic: «AWM 8.2.2 taskbar buttons not minimising / restoring windows , Strange z-order and maximise / minimise behaviour » on forum: Technical Support   Views: 24702
 
David Lomas
Advanced user
 
Posts: 369
Joined: 16.03.2006
Posted: 12.03.2015 16:37:57
 
 
Having disabled Synergy's service, and stopped the client, then rebooted and logged in with no other software running (other than RocketDock), I can confirm I still see the same behaviour with AWM's taskbar. Stopping AWM and using the default windows taskbar operates as expected.

I also disabled 'Activate window on mouse hover', but the inability to minimise windows from their taskbar icon is still there.
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 12.03.2015 19:36:51
 
 
David,

Please create a new User Account on your system, switch to the new user, make sure that RocketDock or other additional applications are not running, then run (or install and run) Actual Window Manager and check whether you are able to reproduce the problem under the new User Account or not.
The test is needed to check whether the problem is related to a conflict with other software or not.

Best regards.
 
Top
David Lomas
Advanced user
 
Posts: 369
Joined: 16.03.2006
Posted: 12.03.2015 22:21:29
 
 
Grr. I logged in under a new user profile, and everything worked as it should, so I logged back in as my regular user profile, and still everything is working again! So, I've no idea what triggers this problem - I'm pretty sure it'll be back, but you'll have to leave it with me until I can figure out what causes it to appear. I'm using Synergy again, and still have the strange SublimeText drag fault (15 windows updates today, one or more of which broke Synergy again :( ), but that doesn't seem connected with this taskbar minimise / restore problem. Unless it fix it :) Who knows. I'll keep an eye on things and update here with more info when I have it.
 
Top
David Lomas
Advanced user
 
Posts: 369
Joined: 16.03.2006
Posted: 12.03.2015 22:36:39
 
 
Ha! Found it. It's (unbelievably) the Sidewise Chrome extension I'm using! I just noticed the problem came back immediately I started Chrome, and turning this extension off immediately fixes the problem. Turning it on again makes the problem come straight back. I couldn't easily test it in another profile, but hopefully you'll be able to reproduce it? The extension is here:

https://chrome.google.com/webstore/detail/sidewise-tree-style-tabs/biiammgklaefagjclmnlialkmaemifgo?utm_source=chrome-app-launcher-info-dialog

I've emailed my Sidewise settings (screencap) to support, in case they're important.
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 13.03.2015 13:51:53
 
 
David,

When you click a Sidewise taskbar icon, it passes the activation to a Google Chrome window, when you click the Sidewise icon second time it becomes active and a third click will minimize the window only.

The behavior with system taskbars (with Actual Window Manager unloaded) is the same on my test Windows 8.1 x64 machine.

I don't think that this is an AWM's bug.
 
Top
David Lomas
Advanced user
 
Posts: 369
Joined: 16.03.2006
Posted: 13.03.2015 14:45:34
 
 
OK - getting closer! I have a window rule to hide the Sidewise taskbar icon (since it follows Chrome, there's no need for it to have a taskbar entry really), and it seems it's _this_ that triggers the problem. If I disable my rule for Sidewise, all is well, but when enabled I see the minimise / restore problem on _all_ other windows / taskbar icons.
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 16.03.2015 11:30:20
 
 
David,

I created Specific Settings for the "Sidewise" window with the "Remove taskbar entry" option enabled but was unable to reproduce the problem.

Could you provide us your configuration files with Specific Settings for Sidewise again and a step by step description of how to reproduce the problem where no window minimizes after a second click on its taskbar icon (starting with your OS booting)?

Best regards.
 
Top
David Lomas
Advanced user
 
Posts: 369
Joined: 16.03.2006
Posted: 17.03.2015 15:41:54
 
 
Gah! This is a really tiresome bug :(. It's also definitely still connected to Synergy; I've been tracking the Synergy bug here:

https://github.com/synergy/synergy/issues/4349#issuecomment-82197449

Annoyingly, I can solve the problem either by stopping Synergy, or by unloading AWM, or by disabling AWM's Sidewise rule! So, it's practically impossible to figure out exactly what's causing it. However, the Sidewise connection isn't entirely surprising, as there is mention in that Synergy thread above that Chrome windows are particularly prone to causing / spreading this issue.

So, since it looks like there's general consensus that Synergy is causing problems for lots of people, not just me, I'm happy to lay the blame there for now, and it's just unlucky that AWM andSynergy together makes it worse. Until Synergy comes up with a fix, I suggest we pause this issue, and see how it looks once there's a final Synergy fix. I've just started testing 1.7.0-focus-fix on Synergy, but it hasn't completely cured it.
 
Top
David Lomas
Advanced user
 
Posts: 369
Joined: 16.03.2006
Posted: 20.03.2015 23:27:14
 
 
OK, here's an update. Synergy fixed their problem, and the focus / z-order issues appears solved. However, I do still see the minimise / restore from taskbar icon problem when I have the Sidewise 'hide taskbar entry' rule active. If I disable that rule, all is fine. Not this affects _all_ other windows, not just Sidewise. I'll send my config to support via email.

The synergy fixes can be obtain from either this install, which is the latest stable build:

http://synergy-project.org/nightly?filter=stable-3b44f9d

but I'm actually using the beta version now, which is this one:

http://synergy-project.org/nightly?filter=legonigel-focus_fix_gitscrubz
 
Top
David Lomas
Advanced user
 
Posts: 369
Joined: 16.03.2006
Posted: 20.03.2015 23:45:41
 
 
Yes, and also I just installed AWM 8.3b2, and the problem is gone. I'll keep testing and see if it recurs.
 
Top

Messages 11 - 20 of 53
First | Prev. | 1 2 3 4 5 | Next | Last 

User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register