Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «Title button error with Foobar2000 » on forum: Beta Testing   Views: 8946
 
Matt Rasmussen
Advanced user
 
Posts: 107
Joined: 25.05.2008
Posted: 13.11.2009 17:53:35
 
 
I recently installed Windows 7 and am using Beta 2 with a nice little program called Foobar2000, you can find it here.

This is the only program that I've seen act this way. When the program opens, the AWM title buttons appear correct, but if you move the window manually, the AWM title buttons stay at the original location and don't move with the foobar window.  If you minimize the window they minimize, but maximize returns them to the original position, not the new position that you moved the window to.

I hope that made sense...
 
Top
Alexey Fadeyev
Administrator

Moderator
 
Posts: 1389
Joined: 30.09.2005
Posted: 13.11.2009 23:27:12
 
 
Matt, glad to see you here again! :) Thanks for the report, we will surely check this issue and try to fix it in either the upcoming beta 3 of the final version 5.5.

BTW, how could you evaluate the recent changes made in AWM?
 
Top
Matt Rasmussen
Advanced user
 
Posts: 107
Joined: 25.05.2008
Posted: 18.11.2009 08:19:21
 
 
Hey Alexey,

I haven't fully tested out all the features, my work life is pretty hectic right now, I'm sure you know how that goes.

I'll be messing around with it in depth soon I hope, but I continue to use the program everyday, and it saves me a ton of time!


Oh, also as a note, this error does not seem to occur on my Windows XP SP3 machine running B2.  Seems to be limited to W7
 
Top
Alexander Belyakov
Administrator
-retired-
 
Posts: 196
Joined: 07.06.2007
Posted: 18.11.2009 22:43:16
 
 
Matt, we've installed Foobar2000 version 0.9.6.9 (latest stable release on their site), and it seems that there is an incompatibility even in Windows XP - the main Foobar2000 window shows title buttons and extended system menu at first, but then all the buttons disappear, and menu items do not work.

Unfortunately, this incompatibility is caused by one of Foobar's components (namely, foo_ui_std.dll library). I 'd prefer not to dive into technical details. Simply put, one of the functions in this DLL kicks AWMs extension code from the Foobar's main window.

At the moment, there are two possible solutions: 1. I can send you a patched version of foo_ui_std.dll for release 0.9.6.9 (I don't use Foobar, so I cannot guarantee that all its functions will work with this patched version, but at least AWM's features will work in the player :) ); 2. we'll try to contact Foobar's authors and discuss if they can fix their component to support AWM.
 
Top
Matt Rasmussen
Advanced user
 
Posts: 107
Joined: 25.05.2008
Posted: 19.11.2009 07:29:42
 
 
I'd say let's go for all of the above.  :D  
 
Top
Joop van de Wege
Registered user
 
Posts: 1
Joined: 08.12.2009
Posted: 08.12.2009 07:22:38
 
 
Quote
Alexander Belyakov wrote:
At the moment, there are two possible solutions: 1. I can send you a patched version of foo_ui_std.dll for release 0.9.6.9 (I don't use Foobar, so I cannot guarantee that all its functions will work with this patched version, but at least AWM's features will work in the player :) ); 2. we'll try to contact Foobar's authors and discuss if they can fix their component to support AWM.
Can you please PM the patched dll?

I saw your thread on the foobar forum and the rather blunt way they treated your question about help  :evil:

Tried myself to patch the dll but that ended not so successful. The location you pointed to is a little bit off and just patching the call didn't work.

Regards,

Joop
 
Top
Alexander Belyakov
Administrator
-retired-
 
Posts: 196
Joined: 07.06.2007
Posted: 10.12.2009 01:36:36
 
 
Joop,

I'm afraid we cannot send you the DLL, since this would violate fb2k's license (as was correctly noticed in that thread).

Actual Tools is not related anyhow to foobar2000 product, and we can not and will not provide any kind of support for this product.
If you need this incompatibility to be fixed, please contact authors of fb2k. Perhaps, if their users will ask, they will remove this limitation from fb2k.
 
Top
Alexander Belyakov
Administrator
-retired-
 
Posts: 196
Joined: 07.06.2007
Posted: 28.01.2010 21:57:53
 
 
To all interested in foobar2000 and AWM compatibility.

Our beta tester Scott has reported that he was able to make fb2k compatible with AWM by selecting Columns UI as User interface module in fb2k.

It really works, so if you want to use AWM features in fb2k, we'd recommend you to use this UI module.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register