Forums list
New topics
Topics list
Search
Help
Login
Register

Messages 1 - 10 of 12
First | Prev. | 1 2 | Next | Last 

Topic: «[Possible Bug] AWM 5.5 Beta 1 - Crash Explorer , Window Rules on Folders Crashes Explorer » on forum: Beta Testing   Views: 27321
 
Joseph Sullivan
Registered user
 
Posts: 44
Joined: 21.02.2007
Posted: 02.10.2009 14:24:40
 
 
Operating System - Windows XP SP3
Program Version - Actual Windows Manager Version 5.5 Beta 1

Note:  I cannot reproduce the bug, so I'm not positive exactly what change caused this.  I will keep trying to reproduce, with logging turned on, and be more cognizant of what order of steps lead to an issue.

I am on a clean install of Windows XP SP3.  All drives are updated and all Microsoft Updates are installed.

I installed Actual Windows Manager Version 5.5 Beta 1 to begin building my preferred set of window rules.  I started with Folders, specifically 'My Computer'.

I have zipped up the contents of WindowRules.ini and placed on my web server, located at:  http://www.developershare.com/doc/WindowRules.zip.  NOTE:  Please let me know when I can remove this file from my server.

As you can see, the rule works just fine.  During the set up of this rule, I was going between Position and Size, trying to get it exactly as I wanted it.  I had turned off Position -> Restrict Placement, saved it, changed something else, turned on Position -> Restrict Placement, etc.  I can't remember, unfortunately, the exact order.

At this point, explorer.exe locked up.  I was unable to work with the folder and moving the window for Actual Window Manager gave me the unpainted look (honestly not sure what the right term is - when explorer locks up, the background no longer repaints, giving windows a vapor-trail effect).

I closed the My Computer process, which forced explorer.exe to restart.  Rebooted and I've seen no ill effect.

At this point, I'm both baffled and a little afraid.  I can't figure out the exact source of the issue, can't reproduce it.  On the same hand, crashing explorer.exe isn't my idea of a good time.  Makes me a little wary to keep using it.

Please advise.  Thank you!
 
Top
Tatiana Jack
Administrator
 
Posts: 616
Joined: 06.08.2008
Posted: 06.10.2009 07:38:01
 
 
Dear Joseph,

Thank you for your detail report.

I downloaded your WindowRules file to our base. You can remove it from your server.

Beta version is an unstable version by definition. We are thinking it was a some glitch with the program.  

E-mail: support@actualtools.com
 
Top
Joseph Sullivan
Registered user
 
Posts: 44
Joined: 21.02.2007
Posted: 06.10.2009 07:48:44
 
 
Oh, no doubt.  That's why I'm trying to find any many issues as possible.  :)

Random stupid question:  is there an IRC chat room or something where I could hanker down with a dev or tester or something?  I'm almost finding more things than I can report, although I'm not sure what's important, what's been reported, etc.

If it helps, I'm on live.com, gmail.com, etc.

Thanks.
 
Top
Joseph Sullivan
Registered user
 
Posts: 44
Joined: 21.02.2007
Posted: 06.10.2009 17:31:38
 
 
Happened again.

I just installed fences and was configuring my folder windows to open around the fences.

I changed Position -> Change Window Position Automatically -> Horizontal Shift from '18% of current monitor' to '22% of current monitor' and Position -> Change Window Position Automatically -> Left from '18% of current monitor' to '22% of current monitor'.  The minute I saved the configuration, explorer.exe locked up.  All folders, the desktop, start bar, etc.

I'm getting a little afraid to use it now.

Again, this is a clean WinXP install.  Fully updated.  All drivers current.  I've ran full / complete scans with Avira, Ad-Aware, and Malwarebytes' Anti-Malware.  I've done everything I could think of.  I looked at the log, EventLog.ini, the Event Viewer and could glean no information.

I'll be happy to email you a copy of msinfo32 or a HijackThis log or whatever I can to help find the root of the problem.  Honestly, it's driving me crazy.

Thanks!
 
Top
Razon
Registered user
 
Posts: 5
Joined: 30.10.2009
Posted: 31.10.2009 01:40:56
 
 
I've also come across the explorer process and even every process freezing because of loading AWM (Load Actual Window Manager), with the only way out being ctrl alt delete ending every task and restarting.

It's mainly just explorer that freezes in more recent versions of AWM, I noticed that this doesn't happen if you keep the mouse in one position and don't do anything after you start the load. So I assume that this has to do with a call being made while it's in the process of loading, and it resulting in some kind of freeze crash because calling something that hasn't completely loaded yet.

This glitch has been around since I first started using AWM in version 5.1, it could have existed long before this version though.


New issue in 5.5b2 that occurs after this glitch happens, after explorer freezes and you ctrl alt delete it and re-run it from the task manager. If you try and do a basic task like copying or cutting a file, or right clicking on a file without unloading AWM (reloading after optional)- then explorer will lockup again. Also on AWM unload after explorer freezing, sometimes a program or two crashes.


On a side unrelated note, in 5.5b2 I've noticed some programs crashing or windows just closing after switching from using an older AWM version like 5.2-5.3 to 5.5b2 (as in loading an older version, unloading it and then loading the new version, for the windows just closing without an error you may need to click and do something in them for this to occur).

Also after having had an older version loaded, unloaded, loading 5.5b2, and then dragging something on the system tray caused this error- and the left most program on the tray to crash. Which was followed by explorer being shut down by data execution prevention and crashing, then on awm unload explorer crashed with this error- the same that the program that was on the tray that crashed first errored out with.

_______________
OS: Windows XP Home SP2
 
Top
Jim Esser
Registered user
 
Posts: 4
Joined: 29.06.2009
Posted: 31.10.2009 10:00:12
 
 
I've had this same problem with the explorer process then all processes freezing after loading AWM - I think it started at 5.2 or 5.3 - on Vista 32
 
Top
Joseph Sullivan
Registered user
 
Posts: 44
Joined: 21.02.2007
Posted: 31.10.2009 11:41:17
 
 
I'm glad that I'm not going crazy, although I wish others weren't experiencing the same issue.  It's incredibly frustrating.

It's to the point that I really can't use the product anymore - and that's coming from a huge fan of the product.

As always, please let me know if there's anything I can do to assist.  Thanks.
 
Top
Alexey Fadeyev
Administrator

Moderator
 
Posts: 1374
Joined: 30.09.2005
Posted: 02.11.2009 12:14:36
 
 
Gentlemen,

Thank you for providing us the feedback. Most of Explorer lockups have been fixed in the 5.5 beta 2 so everyone who reports this problem should check if it's still present in the latest beta.

Razon, the special note for you and others who have several versions of AWM installed on the same PC: 5.5 beta 2 is incompatible with previous versions, so that after launching any version earlier than 5.5 beta 2 you should at least log off (or even reboot) before launching 5.5 beta 2 - otherwise, you'll end up with crashing of all running application.
 
Top
Jolly Wykoff
Registered user
 
Posts: 44
Joined: 08.10.2009
Posted: 02.11.2009 22:56:46
 
 
It is worse in beta2, however, I have to say, I have upgraded my Windows Vista Home Premium 32 to Windows 7 Home Premium 32. I think it is worse because I moved to Windows 7. Probably?
 
Top
Alexey Fadeyev
Administrator

Moderator
 
Posts: 1374
Joined: 30.09.2005
Posted: 03.11.2009 13:34:26
 
 
Please check this issue with the updated beta 2: re-download the setup and re-install AWM 5.5 beta 2 on your machine. We hope that most bugs have been fixed.
 
Top

Messages 1 - 10 of 12
First | Prev. | 1 2 | Next | Last 

User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register