Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «[SOLVED]Drag Desktop Divider , Window/Application sticking/non-sticking » on forum: Beta Testing   Views: 2012
 
Zardoz2293
Advanced user
 
Posts: 302
Joined: 27.07.2010
Posted: 27.08.2014 19:49:05
 
 
I've discovered a bug (with the following configuration):

(a) AWM > Mouse > Drag and Scroll > Make the entire window area responsive to dragging/sizing > CTRL+ALT (Enabled)

(b) AWM > Mouse > Multiple Monitors > Tight monitor boundaries 0.2 sec (and it is super easy to replicate when set to 0.3 sec)

© AWM > Desktop Divider > Enabled Desktop Divider (Enabled) > Always (Sel ected)

(d) Monitor #1 (left-primary), Monitor #2 (right-secondary)

When moving fr om #1 to #2 while CTRL+ALT and dragging an application (left to right), the application gets "stuck" (pulled to what appears the Tile Frame, but its not on it as it is sticking about twice the distance of the Tile Preview width fr om the Tile Preview) before the monitor boundary and yet this doesn't occur when on monitor #2 (moving to the right, off screen). I'd expect to see the same behavior.

I also encountered another bug while performing the above process to see why the application was sticking in the strange spot. Link:
http://www.actualtools.com/forum/read.php?TOPIC_SUBSCRIBE=Y&FID=12&TID=&MID=14448#message14448

Sincerely,
Lars
 
Top
Alexander Mihalkin
Administrator

 
Posts: 502
Joined: 21.04.2014
Posted: 27.08.2014 20:37:44
 
 
Dear Lars,

thank you for your bugreports!

I haven't managed to reproduce both issues. Could you please send us your configuration files?

support@actualtools.com
 
Top
Alexander Mihalkin
Administrator

 
Posts: 502
Joined: 21.04.2014
Posted: 27.08.2014 21:04:34
 
 
And to me it seems like you might be talking about "Snap to Desktop Divider tiles" feature. Please try to deactivate it at Actual Window Manager -> Options -> Window Snapping -> Classic -> To DD tiles and check if there are changes.

support@actualtools.com
 
Top
Zardoz2293
Advanced user
 
Posts: 302
Joined: 27.07.2010
Posted: 27.08.2014 21:11:27
 
 
Quote
I haven't managed to reproduce both issues. Could you please send us your configuration files?
Configuration file sent.

Interesting. I'm not getting that behavior myself. However, I did experience just now different snapping behavior when I used CTRL+ALT left-click on the TITLE/CAPTION bar and I received NO snapping activity. Then I released the keys and mouse button, moved mouse pointer into same application area non-title area CTRL+ALT left-click and snapping was occurring exactly as one would expect (the above concern was not occurring). I also have the "Put into Tile" title button active, which didn't not exist previously when I was testing and reproducing the above.

Thanks,
Lars

UPDATE:
The behavior now appears to be working so there is some procedure in AWM which if you do it you get the results I've expressed. Not sure what it is yet. I performed the process above and encountered Microsoft Outlook 2013 lost the keyboard "Delete" key ability after performing my CTRL+ALT left-click moving from monitor back to monitor (never releasing the window), the long you perform this action the higher the probability something funky occurs. I've now had about four different strange things happen when doing this process.

Sincerely,
Lars
 
Top
Zardoz2293
Advanced user
 
Posts: 302
Joined: 27.07.2010
Posted: 27.08.2014 21:42:08
 
 
Quote
And to me it seems like you might be talking about "Snap to Desktop Divider tiles" feature. Please try to deactivate it at Actual Window Manager -> Options -> Window Snapping -> Classic -> To DD tiles and check if there are changes.
The cause of the problem was directly related to "To other windows (checked/enabled)"

Thanks!

Sincerely,
Lars
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register