Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «[SOLVED] Bug in Configuring Settings on the AWM Window » on forum: Beta Testing   Views: 33268
 
chgoguy7
Advanced user
 
Posts: 88
Joined: 28.02.2006
Posted: 02.03.2006 18:04:37
 
 
After setting a window size and checking off the save screen position option for the Actual Window Manager window itself and clicking on Save, all running applications, including applications running only in the system tray, are all maximized simultaneously. Several applications also ceased to function correctly.

I am e-mailing separately the config file that I had saved just as this problem occurred. Thanks!

Nick

P.S. After disabling the settings I had configured for the ATW window, saving the new config file, and then rebooting my PC, upon starting ATW again, all windows again maximized and applications started behaving eratically. So perhaps this problem is not solely due to the configurations I made to the ATW window, but it is at that point that the problems began. I may begin again with with a fresh install.
 
Top
Alexey Fadeyev
Administrator

Moderator
 
Posts: 1389
Joined: 30.09.2005
Posted: 11.03.2006 07:13:16
 
 
Nick, thanks for the feedback. I have to say that the reason of such erratic behavior is you've turned on some actually restricted options for "All Windows" namely "Resize at startup to", "Save Size on Exit", "Save Position On Exit". Their implementation is incorrect for "All Windows", so you should turn them off to restore the normal AWM behavior.
 
Top
chgoguy7
Advanced user
 
Posts: 88
Joined: 28.02.2006
Posted: 18.03.2006 13:06:55
 
 
Thanks for the response, Alexey.

After running into numerous problems using the "All Windows" options in the past, I have not used any "All Windows" options since. So the problem that I describe above occurred without using any "All Windows" options.

I am resending the config file I saved after the problems described above first began. I tried this same config file with Beta 2 and again experienced the same issues. I have since started over from scratch.  
 
Top
Alexey Fadeyev
Administrator

Moderator
 
Posts: 1389
Joined: 30.09.2005
Posted: 23.03.2006 08:25:40
 
 
Nick, as I said before the main reason of such undesired windows behavior is that "All Windows" options (Save Size, Save Position, Change Position at Startup) are turned on. Yes, in the config file you resent to me these options are still turned on. You can't see it in the beta 2 Configuration Module because there the corresponding visual controls are absent: we remove them to block the access to these problems-causing options. But if you run the beta 1 Configuration with this your settings file you'll see that all the options I told you before are enabled. Trust me! ;)

The second but less significant reason is that you defined the Target Window in AWM's rule incorrectly. It's main window's class isn't TApplication. Actually Configuration opens two different windows: TApplication (hidden service window) and TUIMainForm (main UI window).
 
Top
Guest
Guest
 
Posted: 23.03.2006 13:58:49
 
 
Thanks for the reponse, Alexey.

That explains it then. The "All Windows settings appears to all be disabled but I was using Beta 2 when verifying this. Sorry about that, and I certainly take your word for. I hope it didn't take too much of your time to check into this.

As for the AWM settings: Thanks for the clarification. I'm not sure where I got the window class of Tapplication but I have since (and successfully) configured the AWM window using the TUIMainForm window class.

Thanks again for your reponse!

Nick
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register