Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «Initially force window activation , Initially ignore window deactivation » on forum: Feature Requests   Views: 10769
 
Jermain Lundie
Registered user

 
Posts: 21
Joined: 02.02.2011
Posted: 02.02.2011 00:32:59
 
 
In Windows 7, a window depending on how it was opened or what's being done while it's opening will sometimes wrongly loses focus/activation on it's first appearance (without any mouse clicks taking place).  It's painfully obvious with any one of minimize/rollup/transparency/etc. while inactive enabled.


Having a new startup option to initially force activation or initially ignore deactivation at startup would fix these fluky situations.

Maybe it could work by ignoring standard Windows requests for activation of other windows and only lose activation if the user actually clicks in another window.


Windows 7 Pro (SP1) 64-bit
Actual Window manager 8.14.1
Intel Core i7-960 @ 3.2GHz
24GB (6x4GB) RAM
Nvidia GeForce 9800 GT
 
Top
Vasiliy Ivachev
Administrator
-retired-
 
Posts: 2073
Joined: 09.11.2010
Posted: 02.02.2011 03:47:37
 
 
Hello Jermain,

I can't reproduce this problem on my computer.

What applications do you have this problem with?

What other software do you have?

Best regards.
 
Top
Jermain Lundie
Registered user

 
Posts: 21
Joined: 02.02.2011
Posted: 02.02.2011 09:28:44
 
 
I'm running Win7 Pro 64-bit & Actual Window Manager 6.3 ;)

Setting up AWM to make inactive windows 25% transparent (I never use make transparent at startup) is how I became aware of this. Sometimes, occasionally & randomly, when a program's window first appears (which should always make it the top most z-order window) it will have the 25% transparency applied. Clicking in such a window will still not cause it to become opaque. I have to click elsewhere, to make another window the active window, then a click in the wrongly-transparent-window will make it become opaque as it should have been.

:idea: It's as if AWM occasionally sees the window as inactive even though it actually is the active window, I'm assuming that's why a direct click to the window won't make the transparency go away.

The most common culprits:
  • Winamp 5.581 w/ ClassicPro Skin - docked to right edge of screen in auto-hide mode
    launch method = pinned to taskbar
  • jDownloader
    launch method = desktop shortcut
  • Directory Opus
    launch method = double-click desktop
  • Process Explorer
    launch method = tray icon click
This bug can happen with any standard window, but since it's rare and seemingly random can't be easily reproduced.

Winamp is the most unique case with all the specific window customization it has, and it being pinned to my taskbar. I don't use transparency on it seeing as it already has its own; but it often launches minimized for no apparent reason causing the main docked-window to appear completely blank :o until I click winamp's taskbar item. Setting it to launch maximized|normal doesn't help this issue.

Turning on Control Panel\All Control Panel Items\Ease of Access Center\Make the mouse easier to use > 'Activate a window by hovering over it with the mouse' seems to make the false deactivation problem even more rare. It's hard to know for sure seeing as it's a rare bug to begin with.

I think/hope that some sort of 'initially ignore deactivation' option will fix this.

Thanks.

Windows 7 Pro (SP1) 64-bit
Actual Window manager 8.14.1
Intel Core i7-960 @ 3.2GHz
24GB (6x4GB) RAM
Nvidia GeForce 9800 GT
 
Top
MainTrane
Registered user

 
Posts: 21
Joined: 02.02.2011
Posted: 02.02.2011 11:21:04
 
 
Quote
Turning on Control Panel\All Control Panel Items\Ease of Access Center\Make the mouse easier to use > 'Activate a window by hovering over it with the mouse' seems to make the false deactivation problem even more rare. It's hard to know for sure seeing as it's a rare bug to begin with.

Scratch that :cry: , it just happened again when I opened a folder from the taskbar.

Opening pinned taskbar items or desktop shortcuts with other windows already open seems to be the best way to reproduce this flaw, though it's not always recreated.

Again, the way I visibly see this is by setting windows to become transparent when deactivated (delay/no delay doesn't matter).

Windows 7 Pro (SP1) 64-bit
Actual Window manager 8.14.1
Intel Core i7-960 @ 3.2GHz
24GB (6x4GB) RAM
Nvidia GeForce 9800 GT
 
Top
Vasiliy Ivachev
Administrator
-retired-
 
Posts: 2073
Joined: 09.11.2010
Posted: 08.02.2011 23:25:41
 
 
Hello Jermain,

Thanks for the post.

We'll investigate this problem.

Best regards.
 
Top
MainTrane
Registered user

 
Posts: 21
Joined: 02.02.2011
Posted: 31.03.2011 10:55:00
 
 
OK, I think I've solved this issue.

MS changed window behavior in Win7, making it so that newly opened windows are often denied permission to jump to the top of the z-order (supposedly to prevent pop-up windows from stealing focus).  Sadly, this change affects all windows, not just pop-ups.

Going to the following registry entry, HKEY_CURRENT_USER\Control Panel\Desktop REG_DWORD=ForegroundLockTimeout, and changing from a default value of 200000ms to 0ms seems to have cured the problem of windows opening in the background and without focus:

Code
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Desktop]
"ForegroundLockTimeout"=dword:00030d40

Code
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\Desktop]
"ForegroundLockTimeout"=dword:00000000


Save the second piece of code as a .reg file and run it to set the value to zero, the first bit of code sets it back to the default value.

Still don't know why absolutely no one at ActualTools could reproduce this problem.  200,000 milliseconds is the default value, See Here, I would expect it to cause the same issues I was experiencing for anyone running Win7 (with Aero) and using the AWM settings described in this thread.

Thanks


Windows 7 Pro (SP1) 64-bit
Actual Window manager 8.14.1
Intel Core i7-960 @ 3.2GHz
24GB (6x4GB) RAM
Nvidia GeForce 9800 GT
 
Top
Vasiliy Ivachev
Administrator
-retired-
 
Posts: 2073
Joined: 09.11.2010
Posted: 31.03.2011 21:56:30
 
 
Hello Jermain,

Thanks for the information.

We'll consider adding this information to our FAQ.

Best regards.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register