Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «[SOLVED] Chrome won't run Custom Keyboard Macro in AWM » on forum: Technical Support   Views: 235
 
Robert Hall
Registered user
 
Posts: 14
Joined: 09.02.2022
Posted: 20.04.2022 20:59:26
 
 
Howdy,
 I have a form I fill out the same way 2-3 times a week in Google Chrome. So I wrote a custom hotkey keyboard macro to tab through the form and fill out the required fields. However, the command won't execute in Chrome. I can get it to execute in Word and Excel, but nothing happens in Chrome. I've tried this on my form, but also in Google Sheets and Docs; it appears to be a Chrome issue that won't let the code run.

Attached is a photo of my macro. I've tried changing the 'key combination' that calls the code, but any type of combination fails to call the code to run when Chrome is the active application. Any thoughts on how to overcome this?

 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3801
Joined: 04.04.2012
Posted: 23.04.2022 12:33:13
 
 
Hello, Robert

Thank you for contacting us.

I was unable to reproduce the problem. For me the same keyboard macro with the same key combination works in Google Sheets and in one other site. As I know from your other topic, you disable the Specific Settings for Chrome in order to avoid the other problem. Please make sure there is no Exclusion for Chrome in AWM exclusions list (AWM configuration module > Window Settings > Exclusions) and the Chrome window is affected by AWM at all.


Best regards.
 
Top
Robert Hall
Registered user
 
Posts: 14
Joined: 09.02.2022
Posted: 25.04.2022 20:30:13
 
 
Bogdan,
That was it. It turns out I did have Chrome on my exclusions list. The Macro now works. Thanks!
 
Top
Robert Hall
Registered user
 
Posts: 14
Joined: 09.02.2022
Posted: 25.04.2022 20:37:03
 
 
Bogdan,
I wanted to mention that I'm still having the issue where my 'ctrl' and 'alt' keys are 'sticking' after the macro is run. Is a fix for this still in the works in a future update? Please let me know, thanks.
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3801
Joined: 04.04.2012
Posted: 16.05.2022 19:25:43
 
 
Hello, Robert

Quote
I wanted to mention that I'm still having the issue where my 'ctrl' and 'alt' keys are 'sticking' after the macro is run. Is a fix for this still in the works in a future update?
Unfortunately, we haven't managed to start working on this problem yet. But it's in the database of the problems and we'll notify you when the problem is fixed. Although, for now there is no time frame for when the problem will be fixed.


Best regards.
 
Top
Robert Hall
Registered user
 
Posts: 14
Joined: 09.02.2022
Posted: 16.05.2022 19:27:38
 
 
Thank you for the update.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register