Forums list
New topics
Topics list
Search
Help
Login
Register

Messages 1 - 10 of 17
First | Prev. | 1 2 | Next | Last 

Topic: «AWM Performance Issues with W10 1909 » on forum: Technical Support   Views: 18906
 
David K
Registered user
 
Posts: 2
Joined: 26.04.2020
Posted: 26.04.2020 22:30:45
 
 
I just recently upgraded my setup to 3 x 4k Monitor, new CPU/Board/RAM/SSD and have performace issues to a degree where i prefer having AWM paused or turned off to be able to be productive.
I am using AWM since a couple of years and since i also did a long overdue update from w10 1603 to 1909, if i can recall correctly the issue started with 1909.
I was considering there was a problem with the inplace upgrade so i did a clean install.
Then i bought the product again since i was using a 2 years old version, same result with 8.14.3.

As soon as i start using AWM the Windows UI gets extremly sluggish. Moving windows is choppy, opening the startmenu takes seconds. Windows explorer in general is slow as hell. Everything goes away as soon as i disable or pause AWM.

I disabled a couple of features like audio switcher and the idicator for the winow position while moving.
While it seems like with every feature i disable it gets a tiny bit better the overall performance is unusable.

I am using a powerfull PC and AWM is not using a lot of CPU or anything.

My Setup:
I7-9700K
Z390 Board
32GB RAM
GTX 1080
M2 PCI4x SSD
3 x Asus VP28U 4K Monitors connected via DP

Please let me know if there is anything i could try.

Thanks
David
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3817
Joined: 04.04.2012
Posted: 28.04.2020 04:45:00
 
 
Hello, David

Thank you for contacting us.

Could you open the Task Manager (Ctrl+Shift+Esc combination), reproduce the issue and see what processes have the highest values of the CPU and Memory parameters (in Windows 8 and  10 - the Details tab) when the system is slowed down. Let us know the results.

Could you also disable the mouse-oriented options: AWM configuration module > Mouse > Drag and Scroll (all options), Multiple Monitors (Tight Monitor Boundaries and Wrap the Desktop). Also AWM configuration module > Multiple Monitors > Screen Saver > Save Idle Screens > Start automatically. Apply the changes and see whether the problem still persists. Let us know the results.

What are your DPI settings for each monitor (the "Change the size of text..." option in the system Display Settings)?

What security software you're running (anti-virus, firewall etc.)?


Best regards.
 
Top
David K
Registered user
 
Posts: 2
Joined: 26.04.2020
Posted: 29.04.2020 04:21:58
 
 
Thanks for your reply.

I changed the settings according to your instructions without success.
Desktop scaling is 150% (recommended) but same issue at 100%. All other details you should be able to get out of the Configuration files.
Running Windows Defender Antivirus and Windows Firewall.

I will send you a demonstrationg video and configuration files via E-Mail.
Let me know if there is anything else i can try or information i can provide.

Thanks
David
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3817
Joined: 04.04.2012
Posted: 19.05.2020 16:55:13
 
 
David,

Sorry for the delay.

We haven't received your files. What email address you've sent them to?

Could you send them to bogdan@actualtools.com?


Best regards.
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3817
Joined: 04.04.2012
Posted: 23.05.2020 22:26:40
 
 
David,

Thank you for the provided materials.

Could you check whether the problem is associated with using mouse – put away the mouse temporarily and try using the Win+Left/Win+Right hotkeys to move windows (for example Notepad windows) – does the problem persist in this case?

Could you also exclude one of the windows (for example Windows Explorer) – Manage window settings title button (the one with the wrench icon) > Exclude this window. Press Apply in the opened Exclusion window, make sure the window is excluded now – it should not have any signs of being processed by Actual Window Manager, eg. shouldn't have extra title buttons. See whether the problem persists for this window.

Also please open the installation folder (by default it's C:\Program Files (x86)\Actual Window Manager) and see the Compatibility settings in the properties of the files ActualWindowManagerCenter.exe and ActualWindowManagerShellCenter64.exe. Whether there is some compatibility mode enabled for any of these files?


Best regards.
 
Top
xbit
Registered user
 
Posts: 5
Joined: 28.05.2020
Posted: 28.05.2020 01:31:38
 
 
Same issue when i moved to 4 monitors. With Ryzen 2950x + 128MB RAM. Task manager don't show that smth waste my resoures, but everything go so slow with AWM. And yes when i pause AWM everything works perfecly fast. Simple FHD monitors and GTX 1080 video card. Win10 PRO 1903 64x

Any solves of this problem instead of turn of AWM?
 
Top
xbit
Registered user
 
Posts: 5
Joined: 28.05.2020
Posted: 28.05.2020 01:42:45
 
 
After switching off special setting for Chrome and Opera it works noticeably faster, but I'm not sure I can deal with it.
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3817
Joined: 04.04.2012
Posted: 29.05.2020 23:04:28
 
 
Hello, xbit

Thank you for contacting us.

Unfortunately, problems of this type happen on some users' computers, and they may have different causes. We haven't managed to determine the causes for all of them. For now we're not sure what causes the problem in your case.

Do you mean the problems started as soon as you connected the new monitors? Or you've changed the computer entirely?

Have you tried disabling the mouse-oriented options as suggested above in this topic: AWM configuration module > Mouse > Drag and Scroll (all options), Multiple Monitors (Tight Monitor Boundaries and Wrap the Desktop). Also AWM configuration module > Multiple Monitors > Screen Saver > Save Idle Screens > Start automatically.

Could you also perform the tests I suggested to David:
Quote
Could you check whether the problem is associated with using mouse – put away the mouse temporarily and try using the Win+Left/Win+Right hotkeys to move windows (for example Notepad windows) – does the problem persist in this case?

Could you also exclude one of the windows (for example Windows Explorer) – Manage window settings title button (the one with the wrench icon) > Exclude this window. Press Apply in the opened Exclusion window, make sure the window is excluded now – it should not have any signs of being processed by Actual Window Manager, eg. shouldn't have extra title buttons. See whether the problem persists for this window.

Also please open the installation folder (by default it's C:\Program Files (x86)\Actual Window Manager) and see the Compatibility settings in the properties of the files ActualWindowManagerCenter.exe and ActualWindowManagerShellCenter64.exe. Whether there is some compatibility mode enabled for any of these files?


Best regards.
 
Top
xbit
Registered user
 
Posts: 5
Joined: 28.05.2020
Posted: 06.07.2020 01:37:47
 
 
All this stuff was turned off. But it gives just a little improvement.

I have found that Multiple-monitor taskbar slow down a lot my pc. Without this setting it's possible to use 4 monitors setup with AWM. Not perfect, but much better.
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3817
Joined: 04.04.2012
Posted: 08.07.2020 01:15:27
 
 
xbit,

Did the problems start as soon as you connected the new monitors? Or you've changed the computer entirely?

What about these tests? Have you performed them?
Quote
Could you check whether the problem is associated with using mouse – put away the mouse temporarily and try using the Win+Left/Win+Right hotkeys to move windows (for example Notepad windows) – does the problem persist in this case?

Could you also exclude one of the windows (for example Windows Explorer) – Manage window settings title button (the one with the wrench icon) > Exclude this window. Press Apply in the opened Exclusion window, make sure the window is excluded now – it should not have any signs of being processed by Actual Window Manager, eg. shouldn't have extra title buttons. See whether the problem persists for this window.

Also please open the installation folder (by default it's C:\Program Files (x86)\Actual Window Manager) and see the Compatibility settings in the properties of the files ActualWindowManagerCenter.exe and ActualWindowManagerShellCenter64.exe. Whether there is some compatibility mode enabled for any of these files?


Best regards.
 
Top

Messages 1 - 10 of 17
First | Prev. | 1 2 | Next | Last 

User(s) reading this topic
Number of guests: 2, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register