Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «[CONFIRMED] AWM: Minimize Outlook 2019 after start doesn't work » on forum: Technical Support   Views: 819
 
technoid
Registered user
 
Posts: 28
Joined: 01.03.2018
Posted: 30.10.2019 00:56:19
 
 
I am testing Outlook 2019 and Windows 10 in a virtual machine.

It is not possible to minimize Outlook immediately after startup by AWM.

Of course you can start Outlook by setting a shortcut minimized, but then the Outlook setting "hide if minimized" does not yet work and the task icon is not hidden after minimizing.

If Outlook is maximized and I disable and reactivate the rule, Outlook will be minimized.

(With Excel and Word, minimizing after startup works fine.)

Workaround: An AutoIt script which is started by the AWM rule and contains a delay of 5 seconds.

-----------------------------------
OS: Windows 7 SP1 x64
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3297
Joined: 04.04.2012
Posted: 31.10.2019 11:16:58
 
 
Hello, technoid

I was unable to reproduce the problem.

What versions of AWM and Outlook you're running?

Could you name the exact number of your Windows 10 build (type winver in the Search field of the Windows Start menu, press Enter. The Window containing the build number will appear).

Could you open the AWM log window (AWM tray icon context menu > Show log window) and enable logging in it. Reproduce the problem - open Outlook so that specific settings with enabled minmization at startup is applied to it, but minimization fails (clear log before opening Outlook). Then make a screenshot of the log window depicting all the entries that appeared during opening of Outlook and send it to us.


Best regards.
 
Top
technoid
Registered user
 
Posts: 28
Joined: 01.03.2018
Posted: 31.10.2019 23:05:02
 
 
Hello, Bogdan

Thank you for your fast reply.

AWM: 8.14.1 and 8.14.2
Windows 10 Pro 64-Bit: 1903 Build 18362.418
MSO Pro Plus 2019 64-Bit: Outlook 1909 (Build 12026.20344 click-and-run) and 1910 Build 12130.20272 click-and-run)


I also tested the rule with deactivated window class and window name entry, so only with the program path. That doesn't work either.

I have changed my workaround and start Outlook with the following AutoIt script (as an exe file) via the task scheduler (on user logon, with a delay of 20 seconds):

Run("C:\Program Files\Microsoft Office\root\Office16\outlook.exe","",@SW_MAXIMIZE)
If ProcessExists("outlook.exe") Then
  Local $hWnd=WinWait("[CLASS:rctrl_renwnd32]","")
  Sleep(10000)
  WinSetState($hWnd,"",@SW_MINIMIZE)
EndIf
Exit



-----------------------------------
OS: Windows 7 SP1 x64
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3297
Joined: 04.04.2012
Posted: 13.11.2019 01:00:04
 
 
technoid,

Quote
It is not possible to minimize Outlook immediately after startup by AWM.
We were able to confirm the problem. We'll try to fix it and will post in this topic when it's fixed.

For now as workaround you can enable the "Run keyboard macro" action in specific settings for Outlook and set <Win+Down> macro (the standard AWM minimize hotkey) with delay beginning from 0,3 seconds and more. This should minimize the Outlook window correctly.


Best regards.
 
Top
technoid
Registered user
 
Posts: 28
Joined: 01.03.2018
Posted: 13.11.2019 02:08:43
 
 
Hello Bogdan,

thank you very much.

Quote
Bogdan Polishchuk wrote:
..."Run keyboard macro" action in specific settings for Outlook and set <Win+Down> macro (the standard AWM minimize hotkey) with delay beginning from 0,3 seconds and more. This should minimize the Outlook window correctly.

This doesn't work with maximized windows. But <Alt+Space>n works for maximized windows (delay: 12 seconds). :-)

Best regards

-----------------------------------
OS: Windows 7 SP1 x64
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register