Forums list
New topics
Topics list
Search
Help
Login
Register

Messages 1 - 10 of 29
First | Prev. | 1 2 3 | Next | Last 

Topic: «AMM - Change in Monitor Configuration Very Slow , Actual Multiple Monitors technical support request for issues with slowness when changing monitor configuration. » on forum: Technical Support   Views: 1624
 
jhardyua
Registered user
 
Posts: 8
Joined: 24.08.2017
Posted: 24.08.2017 02:57:02
 
 
I'm on Windows 7 running Actual Multiple Monitors 8.11.1. I've noticed that anytime I change monitor configurations, AMM causes my computer to run very slow or hang for roughly 45 seconds to 1.5 minutes. For instance, if I change from one monitor to two I experience the delay. The same delay is experienced on any monitor configuration change which impacts the total number of monitors or display order.

Can you provide a fix for this issue?
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 2595
Joined: 04.04.2012
Posted: 24.08.2017 22:00:40
 
 
Hello, jhardyua

Could you provide information about the monitors connected to the computer – total number of monitors, their resolutions, interfaces, that you use to connect them to the computer (DVI, HDMI etc.).

Do you use USB video adapters or docking station to connect monitors?

Could you open Task Manager (Ctrl+Shift+Esc combination), reproduce the issue and see what the values of common CPU usage and memory usage are (Performance tab) and what processes have the greatest values of the CPU and Memory parameters when the system is slowed down. Let us know the results.

Best regards.
 
Top
jhardyua
Registered user
 
Posts: 8
Joined: 24.08.2017
Posted: 25.08.2017 02:19:21
 
 
Total number of monitors: 3
Resolution: 1920x1080 (all)
Interfaces: DVI -> HDMI, DisplayPort, VGA
Connection: docking station
Performance:
Unfortunately, during the issue Task Manager goes into a Not Responding state so I'm unable to see CPU and memory usage while the issue is occurring. When I look at the Performance tab, I can see the CPU history spikes on all 4 cores during the issue. I can't tell what causes it, though.

If it matters, I experienced the same slowdown on previous configurations. For instance, my previous configuration was dual monitor with DVI and VGA. It still had the same issue.

Let me know if you need anything else.
 
Top
Alex Fadeyev
Administrator

Moderator
 
Posts: 1324
Joined: 30.09.2005
Posted: 25.08.2017 21:21:11
 
 
Thank you for the information. Also, please specify the following:

1) do you change the configuration of monitors via AMM Configuration dialog or via the system Display Settings dialog?

2) is issue the same if you change the configuration via the system Display Settings dialog?

3) is issue the same if you change the configuration via the system Display Settings dialog with AMM unloaded?

Thanks.
 
Top
Chris Miller
Advanced user
 
Posts: 240
Joined: 02.08.2011
Posted: 25.08.2017 21:55:10
 
 
I can provide a little feedback also.  I have experience this issue quite a bit recently.

Any time a game changes the desktop refresh rate/resolution of a monitor, I have the OP's issue.  I have 5 monitors, NOT configured in 2D or 3D surround.

- 3 on bottom are 1920x1080@120Hz(2 DVI, 1 DVI->DisplayPort), 1 top-center is 1920x1200@60Hz DVI, top-right is 1920x1080X60Hz HDMI.
- 3 on bottom are connected to TITAN series 7 Nvidia card, while 2 on top are connected to Nvidia 760 GT video card.
- Tried moving top HDMI to TITAN and top DVI to USB, same issue.
- Tried moving top 2 both to USB, same issue.


I am currently in the process of migrating from Win7 to my new Win10 machine so I don't have any games configured/installed yet.

I at least wanted to make note that I've DEFINITELY seen this issue and the OP is not the only person.  I do not have the original setup anymore to continue testing, but the last thing I was going to do was quit ActualTools and see if I still got the same issue.

Chris
 
Top
Chris Miller
Advanced user
 
Posts: 240
Joined: 02.08.2011
Posted: 25.08.2017 22:00:06
 
 
One other thing I forgot to note.

I've been able to duplicate this issue by doing nothing more than changing a specification setting and clicking Apply.  This only happened the first time I opened AWM Configuration.  After it finished reapplying all the desktop/monitor settings, then subsequent application specifications did not cause this unless I quit out of the Configurator and got back in.

It definitely seems to be AWM forcing the reapplication of monitor settings even when no changes to monitors settings were made.

Chris
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 2595
Joined: 04.04.2012
Posted: 28.08.2017 20:21:55
 
 
Chris,

Thank you for the information. I hope it helps us to figure out what causes problems like this.

Best regards.
 
Top
jhardyua
Registered user
 
Posts: 8
Joined: 24.08.2017
Posted: 28.08.2017 23:49:18
 
 
The issue occurs regardless of how the configurations are changed. Most commonly, it occurs when I undock going from 3 monitors to 1 - the computer becomes unusable for about 45 seconds.

The issue is the same regardless of how the configuration is changed.

The issue does not occur if AMM is unloaded at the time.
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 2595
Joined: 04.04.2012
Posted: 29.08.2017 00:20:03
 
 
jhardyua,

What is your graphics card and what is the version of video driver?

Could you send us your AMM configuration files using the Send to Tech Support tool when all the monitors are connected and enabled (Configuration module > Tools > Configuration > Send to Tech Support)? Please add a link to this topic to the email.

Could you also not connect your computer to the docking station but connect one of the monitors directly to the computer and see whether you're able to reproduce the issue in this case?

Best regards.
 
Top
jhardyua
Registered user
 
Posts: 8
Joined: 24.08.2017
Posted: 29.08.2017 02:41:15
 
 
Intel® HD Graphics 4400
10.18.14.4432

Configuration files sent as requested. I included a link to this topic in the email.

The issue persists when a monitor is connected directly to the laptop as well.
 
Top

Messages 1 - 10 of 29
First | Prev. | 1 2 3 | Next | Last 

User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register