Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «3 Monitors/Set Maximize Desktop to #s 1 & 2 , Window Maximization » on forum: Technical Support   Views: 2586
 
Allen GOLDSTEIN
Registered user
 
Posts: 1
Joined: 11.07.2017
Posted: 11.07.2017 04:39:52
 
 
Using Actual Multiple Monitors, on a Windows 10 3 monitor setup,  is there a way to set the maximize window button for a particular program to go across monitors 1 and 2 only?
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3332
Joined: 04.04.2012
Posted: 12.07.2017 22:14:03
 
 
Hello, Allen

There is the ability to maximize a window across particular monitors via the “Maximize to desktop” extra title button. Right-click this button to open the special preview window which allows spanning the selected monitors only. Select the target monitors which you would like to stretch a window to, as if you select files in a folder: press the left mouse button on a monitor and drag the mouse (without releasing the left button) over desired monitors (the window preview will show you the expected window size). After selecting all desired monitors, release the left button to apply the action.

Best regards.
 
Top
danielk
Registered user
 
Posts: 1
Joined: 11.05.2018
Posted: 11.05.2018 21:46:06
 
 
Hi,

is it also possible to use Remote Desktop Session only on 2 of 3 monitors in full screen? What you are describing is only using the RDP session in a maximized window but not full screen.

I'm currently evaluating Window Manager and am wondering whether this is possible.

Thanks,
Daniel
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3332
Joined: 04.04.2012
Posted: 16.05.2018 20:58:06
 
 
Hello, danielk

It's a Windows limitation that doesn't allow you to run remote desktop on subset of multiple monitors in fullscreen. There is a workaround for this, although inside the remote system, the monitors you're going to use for RDP, will count as a single monitor. If it's not a problem for you, then you can use the following workaround:

1.
Open the Remote Desktop Connection settings window, adjust the settings (speicify some random resolution in the Display configuration tab, it doesn't matter on this step), go to the "General" tab and save the connection settings as .rdp file (Save As...).

2.
Open the .rdp file with Notepad (by simply dragging the file to the Notepad window). Make sure the following parameters have the specified values:

screen mode id:i:1
use multimon:i:0

Specify the values for "desktopwidth" and "desktopheight" parameters in accordance with the size of the area composed of the monitors you're going to run RDP on. Better use the monitors having the same resolutions. For example, if you want to run RDP on two 1280x1024 displays, then the remote desktop area is 2560x1024 and the parameters should be like this:

desktopwidth:i:2560
desktopheight:i:1024

Probably, you'll have to turn off the smart screen sizing:
smart sizing:i:0

Save the changes.

3.
Adjust the Specific Settings for RDP in Actual Window Manager (create them, if you haven't created by now - AWM configuration module > Window Settings > Specific Settings > green Plus sing icon).

Go to the Target Window section of the settings, specify "TscShellContainerClass" in the Window class parameter field and "\mstsc.exe" in the Window caption field (without quotes), enable these two parameters, leave the window caption parameter unchecked.
Go to Startup section.
- Enable the "Move to monitor" action, select "Exactly specified" and specify the left of the two monitors you're going to run RDP on;
- Enable the "Resize" action, specify the remote desktop width and height in pixels (the same values you've specified in the .rdp file);
- Enable the "Align" action, specify "top-left".
- Scroll down to the bottom of the Startup section, enable the "Change standard window parts" option, specify "Remove" for "Border and title bar" and "Resizable frame".

Apply the changes both in the specific settings window and in the main configuration window.

4.
If you start RDP from the saved file with AWM running, it should be open on two monitors, but the RDP window won't have the blue RDP bar at top, thus there are some problems with managing the window.
You can use AWM taskbars to manage RDP window - enable the "Mirror" mode for the taskbars, and you'll be able to see the RDP icon on the third monitor, when RDP window is open.
For easier RDP window management you can add the Screen Icon – go to RDP specific settings in AWM, Minimizing section > Options > Screen Icon Options > enable the "Permanent" and "Large" options. When the RDP window is open, there should appear the screen icon on the desktop, which you can use to minimize/restore the RDP window.

Best regards.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register