Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «[SOLVED] Possible chrome active window bug with AMM » on forum: Technical Support   Views: 10860
 
Matthew Holmes
Registered user
 
Posts: 5
Joined: 05/04/2017
Posted: 05/04/2017 10:58:41
 
 
I'm experiencing a weird bug and was wondering if anyone else is experiencing it/knows how to fix it. With AMM running, any active chrome window has extremely slow downward scrolling. Scrolling up works fine, and every other application works fine (other browsers, file explorer, steam, xbox app, etc.). If I click off the window to deactivate it or pause AMM scrolling down begins to work again. No idea what is causing this.

Info:
AMM 8.10.2
Windows 10 pro 64 bit
Chrome Version 58.0.3029.96 (64-bit)
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 3996
Joined: 04/04/2012
Posted: 05/05/2017 00:37:08
 
 
Hello, Matthew

Could you send us your AMM configuration files using the Send to Tech Support tool (Configuration module > Tools > Configuration > Send to Tech Support). Please add a link to this topic to the email.

Do you use any mouse management software like Logitech SetPoint for example?

Best regards.
 
Top
Matthew Holmes
Registered user
 
Posts: 5
Joined: 05/04/2017
Posted: 05/05/2017 03:40:30
 
 
Sent. I have been using setpoint for 4+ years and AMM for 3+ with no problems. With setpoint closed the problem still persists. The problem seems to have started after renewing my sub and installing 8.10.2. What it looks like it is doing is scrolling 1 pixel per scroll.
 
Top
Matthew Holmes
Registered user
 
Posts: 5
Joined: 05/04/2017
Posted: 05/20/2017 03:41:26
 
 
Any ideas as to what is causing this? My email hasn't been responded to over the last 2 weeks.
 
Top
Vasiliy Ivachev
Administrator
-retired-
 
Posts: 2073
Joined: 11/09/2010
Posted: 05/22/2017 15:01:58
 
 
Hello Matthew,

Unfortunately, we were unable to find your configuration files. Please specify which email address they were sent from (or specify the email Subject). You could also try to send them again (please don't forget to add a link to this thread).
 
Top
Vasiliy Ivachev
Administrator
-retired-
 
Posts: 2073
Joined: 11/09/2010
Posted: 05/22/2017 15:04:21
 
 
Matthew,

Does the issue persists if you add Google Chrome to the Exclusions list of Actual Multiple Monitors (AMM -> Window Settings -> Exclusions)? Please also try to disable all Google Chrome's extensions and check whether the issue persists or not.
 
Top
Matthew Holmes
Registered user
 
Posts: 5
Joined: 05/04/2017
Posted: 07/17/2017 07:00:48
 
 
So I finally got around to fixing this bug and I found that it is caused by the windows 10 setting for scrolling inactive windows when hovering over them and AMM. Disabling inactive window scrolling in windows 10 settings fixed the problem for me, in case anyone else encounters this problem.
 
Top
Alex Fadeyev
Administrator

Moderator
 
Posts: 1425
Joined: 09/30/2005
Posted: 07/25/2017 03:37:21
 
 
Matthew, thank you for sharing your solution.
 
Top
Chuck
Registered user
 
Posts: 11
Joined: 05/21/2014
Posted: 09/04/2017 00:55:52
 
 
This solved the issue for me as well.

And with the windows setting "scroll inactive windows" disabled, inactive windows DO scroll normally.

Other notes:
1. Issue only affects scrolling down when the browser page is in focus.
2. If the page has a popup "send feedback" or whatever in focus, the page below scrolls fine until put in focus again.  
3. Issue occurs with some chromium flavors, but not others.  Chrome and Canary have the issue.  Chromium, Chromodo Dragon have no scroll issues.  No other windows are affected (and I a lot).
4. Issue varies affecting scroll down between like 10% and 100%, usually it will start to scroll down then bounce back up.  I'm pretty sure this is related to the day of the week, as some days it's better than others.
5. My other use logon works fine with all the browsers, I have not looked at the window setting.
6. With AWM unloaded, there's no issues.
7. Checked AWM window rules with Chrome (3) and all other rules that might somehow get applied based on title, nothing seems to be to blame.
8. Saved all settings and then restored them.
9. Set Chrome excluded via the toolbar 'exclude' option, which is now not showing, because it's excluded.

I installed Chromium and Canary just to test, only home page (google search for testing scroll) was changed.

Warning: Windows Settings is badly programmed.  When opening, it's already focused on the 'left/right' primary button selection, so if you are testing scrolling, it will change this setting, which can have excessive lag and seem to lock up.   Proper windows will deselect the focused control when clicking on a 'blank space' but Microsoft has failed to implement this expected behavior in the new "windows 8" Settings.

I have the latest AWM 8.1x, not beta, upd ated today.

The issue feels like over-acceleration, but I used AHK to show scrolls via tooltip, and se t scrolling to 1 line, and tried different mice, and found the msmouse.inf is loaded.... it does not seem to be a signal issue, but it does feel like one.

Issue started over 4 weeks ago.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register