Forums list
New topics
Topics list
Search
Help
Login
Register

Messages 41 - 50 of 53
First | Prev. | 2 3 4 5 6 | Next | Last 

Topic: «AWM 8.2.2 taskbar buttons not minimising / restoring windows , Strange z-order and maximise / minimise behaviour » on forum: Technical Support   Views: 17183
 
David Lomas
Advanced user
 
Posts: 343
Joined: 16.03.2006
Posted: 28.04.2015 15:49:30
 
 
Here's the latest - still really inconclusive...

I ran for 5 days with AWM loaded and Synergy completely unloaded (service disabled). The problem happened once in all that time.

I then ran for 5 days with Synergy loaded and AWM completely unloaded. The problem didn't appear at all.

I then ran for 3 days with both loaded, and still, nothing happened...

Then, Synergy updated from 1.6.3 to 1.7.1, and now I'm using both together again to see if there's still a problem. I read the changelog for Synergy, and there are maybe a couple of things that have changed which might impact this (something about double clicks / triple clicks).

Whatever it was, it certainly seems to be triggered much less frequently, which is great. I'll post here again if anything changes, or if I can pinpoint the cause.

Tx,

Dave.
 
Top
David Lomas
Advanced user
 
Posts: 343
Joined: 16.03.2006
Posted: 29.04.2015 22:04:39
 
 
And today it happened again. I now have various windows (SublimeText, SearchEverything, PuTTY, cmd.exe, Chrome) all open and refusing to come to the front when 'restored' from the task bar icon. Grrr. Seems definitely linked to running AWM _and_ Synergy together. I had a good 10 days of no problems when running _either_ AWM _or_ Synergy.

Have you been able to run Synergy (server) with AWM and not see any problems?
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 30.04.2015 13:50:41
 
 
Dave,

We can't reproduce and fix a problem without a detailed description of how to reproduce it. We need a step by step description like we provided on the first page of the thread:
Quote
Here is my system info:
Windows 8.1 x64 (Synergy Server), Windows 7 x64 (Synergy Client), Synergy 1.4.18.

Here is the description of how to reproduce the problem (with Actual Window Manager unloaded):
1. Start the Synergy Server and connect to a client;
2. Open Windows Start Screen on the Server machine, then close it;
3. Select a text in a text redactor (MS Word 2013 in my case) on the client machine and don't deselect it (i.e. don't make another click);
4. Return the mouse cursor to the Server machine;
5. Click alternately on an empty space of the system taskbar and on a window taskbar icon and the windows z-order will not be changed.
 
Top
David Lomas
Advanced user
 
Posts: 343
Joined: 16.03.2006
Posted: 01.05.2015 15:11:46
 
 
I know! Here's the closest I can get to that:

1. Start AWM
2. Start Synergy Server
3. Wait for some unknown, unidentifiable trigger
4. Observe problem

I'm still hunting for more detail on 3... However, my question was whether, if you install and start Synergy Server together with AWM, you have _ever_ observed that behaviour?

The only 'fixed' points I have so far are as outlined before:

* With only AWM running (not Synergy), I've seen the problem occur once in 5 days
* With only Synergy running (not AWM), I've not seen the problem occur in 5 days
* With both running, it happened on the second day of testing
* Once triggered, restarting Synergy does not seem to fix the problem. Restarting AWM _does_ resolve the problem (at least temporarily)

Since the upgrade to Synergy (now 1.7.1) and AWM (I've just renewed my subscription to install the release version of 8.3), it happens less often. I fully understand you can't fix something you can't see. I'm just posting here everything I observe so that (a) we've got a full record of everything I've tried, and (b) in the hope that some pattern will emerge leading to a better recipe for reproducing the problem...
 
Top
David Lomas
Advanced user
 
Posts: 343
Joined: 16.03.2006
Posted: 01.05.2015 21:12:27
 
 
One more data point - for what it's worth.

'Something' just triggered the problem. I still haven't found the 'something'... The 2 symptoms were:

* Clicking an applications taskbar icon would give the app focus, but _not_ raise it to the top of the window stack (ChromePortable and MS Word were the 2 apps I noticed it with, but it applied to all apps once it had got in this state).
* Highlighted text in SublimeText cannot be deselected by single-clicking - ST shows the 'drag' icon momentarily during the click, as if the mouse had moved or the button been held down.

I then did these things in this order to recover:

* I 'unloaded' AWM - no change
* I restarted the Synergy service - no change
* I stopped Synergy completely - no change
* I 'exited' AWM - problem immediately vanished

I was then able to start AWM again, and all is functioning normally again. I guess until the next 'trigger'.

One other oddity I noticed whilst recovering from this - not sure if it's connected or not. If I open the Computer Management window (Right-click on My Computer, then 'Manage'), the window (I was using it to stop / restart the Synergy service) can't be minimised by clicking on the taskbar icon with AWM loaded. If I unload / exit AWM, it can be minimised restored using the default Windows taskbar. I notice on the right-click menu the small 'elevated privileges' shield next to 'Manage', so I'm assuming this starts elevated. Perhaps there's something in AWM managing elevated windows that could be a cause?
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 05.05.2015 13:58:58
 
 
David,

I've just tried to reproduce the problem with the 1.7.1 version of Synergy. Actual Window Manager was not loaded. However, the problem can't be reproduced because after starting Synergy the mouse pointer stays at the bottom-right corner of the client primary display and can't be moved (it responds on clicks by doesn't move).
 
Top
David Lomas
Advanced user
 
Posts: 343
Joined: 16.03.2006
Posted: 05.05.2015 15:30:01
 
 
Hmm - that sounds very odd. However, as noted in my earlier posts, the problem I'm having is exclusively with the Synergy server, not client - in fact, it happens whether there are clients connected or not.

I've not come across the 'stuck mouse' issue I'm afraid - does it happen if you switch Synergy to server mode?
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 06.05.2015 13:05:14
 
 
David,

The problem appeared once with Actual Window Manager and Synergy server loaded and didn't appear with Actual Window Manager or Synergy server loaded separately. It seems that dragging a Google Chrome tab into a new window and moving it back to its original window caused the problem appearing. Unfortunately, I was unable to reproduce the problem again.

Could you run another internet browser (e.g. Firefox or Opera) for a few days to check whether the problem is related to Google Chrome?
 
Top
David Lomas
Advanced user
 
Posts: 343
Joined: 16.03.2006
Posted: 11.05.2015 15:54:02
 
 
I'm travelling a lot for the next 3 weeks, so I will probably not have a lot of time to move to a new browser immediately. However, one other thing I noticed is that I cannot pin Chrome to the taskbar in AWM. If I stop AWM, it appears in the standard windows taskbar as a pinned app, but on starting AWM again, it vanishes. I don't know if that's related or should be another forum topic, but it certainly looks like Chrome is misbehaving in various ways perhaps...

This is the version of Chrome I'm using:

http://portableapps.com/apps/internet/google_chrome_portable
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 13.05.2015 16:35:54
 
 
David,

How exactly are you trying to pin Google Chrome portable to a multi-monitor taskbar (dragging .exe or shortcut to the tasbkar, right click a taskbar icon of opened Google Chrome window -> Pin this program to the taskbar etc.)?

Do you have Actual Window Manager installed with the "Support system utilities and administrative tools" option enabled?
 
Top

Messages 41 - 50 of 53
First | Prev. | 2 3 4 5 6 | Next | Last 

User(s) reading this topic
Number of guests: 4, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register