Forums list
New topics
Topics list
Search
Help
Login
Register

Messages 21 - 30 of 53
First | Prev. | 1 2 3 4 5 | Next | Last 

Topic: «AWM 8.2.2 taskbar buttons not minimising / restoring windows , Strange z-order and maximise / minimise behaviour » on forum: Technical Support   Views: 22203
 
David Lomas
Advanced user
 
Posts: 367
Joined: 16.03.2006
Posted: 21.03.2015 00:22:20
 
 
The minimise / maximise problem appears to have gone, but I'm still seeing the weird 'can't deselect text in Sublime Text 3' issue. If I stop AWM, ST3 immediately starts behaving normally again. Stopping synergy and the synergy service appears to make no difference.
 
Top
Susan
Registered user
 
Posts: 22
Joined: 21.10.2013
Posted: 29.03.2015 18:01:50
 
 
Hope you don't mind me jumping in here guys, but am having a similar issue? (I think)
I am not using Synergy. Never have. Have a basic Chrome installation, but never use it.

It does indeed look like a Windows 8.1 Update causes this issue (from the supplied link on page1).
AWM has started to crash occasionally after startup, then after a restart, some time later the window focus issue begins. I've also noticed some corruption of images in Firefox (black areas like the 'Old Days' of Nvidia driver issues - driver had not been updated since well before the focus issue started. Updated now. No improvement).
Stopping and restarting AWM makes the focus issue go away for a while as does the image corruption issue.

Thank you David for posting this - thought I was going mad. Again. ;)

Vasiliy:
Defender is not installed, and Taskbar window grouping is disabled.
Have just sent you my config files. Hope this helps you work out what Microsoft has broken and if there is any fix.

Best Wishes,
Susi xx
 
Top
David Lomas
Advanced user
 
Posts: 367
Joined: 16.03.2006
Posted: 30.03.2015 03:00:31
 
 
From the look of that Synergy thread, there were some very specific and non-security-related changes made in a recent Win 8.1 security update, which the Synergy devs were complaining about. It was connected with various UI flags passed when calling window creation / control functions. I must admit it's _way_ beyond my understanding.

I'm also still seeing the focus bug occasionally, but haven't yet identified a specific trigger - like you Susi, it 'just happens' after a certain amount of time has passed. Given that I use both Synergy and Chrome all day every day, I can't really point the finger at AWM conclusively, but it's quite conceivable that this MS change has triggered problems in multiple places / pieces of software.
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 01.04.2015 16:36:43
 
 
Susi and David,

There were some fixes in current beta versions that might solve these problems.
Could you install our current beta version from http://www.actualtools.com/beta/ and check whether these problems persist or not?

Best regards.
 
Top
Susan
Registered user
 
Posts: 22
Joined: 21.10.2013
Posted: 01.04.2015 19:25:16
 
 
Thanks Vasiliy.
Just installed.
Will report back if the issues continue/fixed.
Susi xx
 
Top
David Lomas
Advanced user
 
Posts: 367
Joined: 16.03.2006
Posted: 10.04.2015 02:04:54
 
 
I've been using 8.3b2 for these tests - can you confirm which beta version had the changes, so I can check?
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 10.04.2015 11:56:42
 
 
David,

The current 8.3 beta 3 version of Actual Window Manager (download link - http://www.actualtools.com/files/aim83b3.exe ) has these changes.

Best regards.
 
Top
David Lomas
Advanced user
 
Posts: 367
Joined: 16.03.2006
Posted: 10.04.2015 14:21:05
 
 
I've just upgraded, and am back testing now. Will update when I know more. Tx.
 
Top
David Lomas
Advanced user
 
Posts: 367
Joined: 16.03.2006
Posted: 10.04.2015 19:06:55
 
 
First impression after half a day is that the minimise / restore from taskbar is much more reliable. However, z-order is really messed up. I can't bring a window to the front by clicking it's title bar or minimise / restoring. It's like other windows have 'always on top' set, even though they don't. I have to minimise them to see what's behind. It's happening with Sublime Text 3, PuTTY and Chrome in equal quantities - very frustrating! Is this new to beta 3 or something different?
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 11.04.2015 17:47:50
 
 
David,

Are you running the beta with the Synergy service loaded?
If yes, please check whether you are able to reproduce the problem under another User Account where Synergy is not installed or not.
 
Top

Messages 21 - 30 of 53
First | Prev. | 1 2 3 4 5 | Next | Last 

User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register