Forums list
New topics
Topics list
Search
Help
Login
Register


Topic: «Ignore Deactivation and Lock Mouse don't work together » on forum: Technical Support   Views: 5137
 
Bertram Vogel
Advanced user
 
Posts: 64
Joined: 14.01.2012
Posted: 31.03.2012 12:47:36
 
 
First, thank you for the "compatibility mode" for ignore deactivation and lock mouse. It works perfect with "The Witcher" (previously these hotkeys did not work with this game).

But there is a problem: Setting "Ignore Deactivation" to true, disables "Lock mouse".

If it start "The Witcher" (fullscreen) and then press the hotkey for "Lock mouse" I can lock (and unlock) the mouse in the witcher window  .
But if i then press the hotkey for "Ignore Deactivation" (which works fine), the mouse is unlocked (if it was previously locked in the window) and pressing the hotkey for "Lock mouse" does not change the setting any longer.
If i then deactive "Ignore Deactivation" using the hotkey, the "Lock mouse" hotkey again works.

This problem also occurs when using the startup options (make a specific window setting for the witcher) and not the hotkeys:
If you check only "Lock Mouse" then the Witcher starts and the mouse is locked in the window  .
If you check only "Ignore Deactivation" then the Witcher starts and it ignores deactivation.
If you check both, then it ignores deactivation, but the mouse is not locked in the window  .


And just a small note:
Checking the "Compatibility mode" for "Lock mouse" disables this functionality in some programs completely (Windows Explorer, Notepad, VLC Media Player, ...). I don't need this functionality in this programs, but maybe the compatibility setting should be a window specific setting (if possible).

Windows XP 32-bit, AWM 7.0

Best Regards.
 
Top
Vasiliy Ivachev
Administrator
 
Posts: 2073
Joined: 09.11.2010
Posted: 04.04.2012 01:33:45
 
 
Hello Bertram,

Thanks for the post.

Quote
But there is a problem: Setting "Ignore Deactivation" to true, disables "Lock mouse".

If it start "The Witcher" (fullscreen) and then press the hotkey for "Lock mouse" I can lock (and unlock) the mouse in the witcher window .
But if i then press the hotkey for "Ignore Deactivation" (which works fine), the mouse is unlocked (if it was previously locked in the window) and pressing the hotkey for "Lock mouse" does not change the setting any longer.
If i then deactive "Ignore Deactivation" using the hotkey, the "Lock mouse" hotkey again works.

This problem also occurs when using the startup options (make a specific window setting for the witcher) and not the hotkeys:
If you check only "Lock Mouse" then the Witcher starts and the mouse is locked in the window .
If you check only "Ignore Deactivation" then the Witcher starts and it ignores deactivation.
If you check both, then it ignores deactivation, but the mouse is not locked in the window .
- The problem has been confirmed. We'll try to fix this.

Quote
And just a small note:
Checking the "Compatibility mode" for "Lock mouse" disables this functionality in some programs completely (Windows Explorer, Notepad, VLC Media Player, ...). I don't need this functionality in this programs, but maybe the compatibility setting should be a window specific setting (if possible).
- Could you clarify what exactly "Compatibility mode" are you writing about?

Best regards.
 
Top
Bertram Vogel
Advanced user
 
Posts: 64
Joined: 14.01.2012
Posted: 05.05.2012 10:19:12
 
 
Hello,

sorry for the late response, i forget to subscribe for this topic and was very busy.

Quote
- The problem has been confirmed. We'll try to fix this.
I can confirm this problem is solved in AWM 7.1 Beta 2 :)

Quote
- Could you clarify what exactly "Compatibility mode" are you writing about?
I am talking about the checkbox "Compatibility mode" under "Hotkeys" -> "Actions" -> "Lock Mouse".
I have to activate this checkbox to make this hotkey work within "The Witcher".
The downside is, that with this checkbox activated, the hotkey no longer works in some applications where it worked before (Windows Explorer, Notepad, VLC Media Player).

Best Regards.
 
Top
Bogdan Polishchuk
Administrator
 
Posts: 2835
Joined: 04.04.2012
Posted: 12.05.2012 03:23:56
 
 
Hello Bertram.

Thanks for the post.

We'll consider the possibility of this improvement.

Best regards.
 
Top


User(s) reading this topic
Number of guests: 1, registered members: 0, in total hidden: 0


Forums list
New topics
Topics list
Search
Help
Login
Register